Which Smart phones are supported by the Easy logger?

Which Smart phones are supported by the Easy logger?

The Easy logger can be installed on all Android smart phones with an Android version of over 2.3.

Posted in: Compatibility